If you have problems on running Rental Ninja mobile App in your mobile phone and your phone is a little old, you might be wondering why the app isn't working for you.

We use Flutter to build our mobile applications. It's quite a new software and it might not work with older hardware.

Find here an screenshot from the Flutter website were you can find the minimum devices and OS versions to run the app:

Did this answer your question?